Your question

HP rx3715 iPAQ Mobile Media Companion

Tags:
  • Windows Phone
  • Mobile
  • Hewlett Packard
  • Ipaq
  • Devices
Last response: in Windows Phone
June 18, 2009 1:29:25 PM

The device hangs at the first screen. It says to tap the screen, but the screen does not respond.

More about : rx3715 ipaq mobile media companion

June 19, 2009 6:23:33 AM

Hi AFI, welcome!

Have you tried a hard reset?

  • Hold down the Mobile Media and iTask buttons.
  • Hold the stylus down on the reset button for a few seconds. Wait until the screen goes dark, then release.
  • Press the reset button again or plug the PDA into a power source to turn the gadget on again.
    July 15, 2009 2:32:27 AM

    I have tried a hard reset, no luck.
    I have tried to reflash the ROM, no luck.
    I have replaced the entire touchscreen, no luck.

    I am running the device from the power cord. The battery is shot and I am unwilling to purchase one if I cannot get the device working. Could the battery - or lack thereof - be causing any problem?

    Thanks for the help.
    Related resources
    Tom’s guide in the world
    • Germany
    • France
    • Italy
    • Ireland
    • UK
    Follow Tom’s guide
    Subscribe to our newsletter
    • add to twitter
    • add to facebook
    • ajouter un flux RSS