Your question
Solved

My Galaxy S4 will not mount ANY SD card

Tags:
  • Micro Sd
  • Galaxy S
Last response: in Android Smartphones
July 11, 2016 12:41:45 PM

My Galaxy S4 has a 16GB internal memory and i was using a 64GB SanDisc Ultra micro SD card all this time with no problems. Now, suddenly, it won't recognize the card. I bought a new 16GB SD card and the phone won't mount it or even recognize it. I can't figure out what has gone wrong

More about : galaxy mount card

July 11, 2016 5:19:46 PM

Well it could be a few different things causing the problem. Here are a few things to try/look for.

1. It could be a temporary phone problem.

To see if it is just a temporary phone problem, "Reboot" the phone. If that does not help you can try a "Soft Reset" by taking the battery out for about 30-45 seconds and then restart the device. Then try remounting the card.


2. The microSD card is not supported by the device.

Check the specs of the card you are trying to use. Make sure they are the same as the phone allows. Most cards available are supporty by the S4, but there are brands that is just doesn't like.


3. Either the microSD card or the slot was damaged.

Check the microSD cards connector and make sure it is not damaged, missing, corroded, etc. After making sure it is ok, then check the cards slot on the phone and make sure there is nothing wrong with it.

If the card(s) are damaged, then just replace them. If the slot is damaged, then you would need to have it replaced. If the phone is under warranty, I would contact the manufacturer to see about replacing it. If it isn't under warranty, you can see about replacing it yourself, or paying someone/somewhere to do it for you.


4. An application is using the microSD card.

Lastly, there could be an app on the phone that is causing the problem. Some third-party apps can cause conflicts. Try testing this out by running the phone in "Safe Mode" and see if the SD card can be mounted then. If it can, then you need to figure out which app is causing the problem.
m
0
l
July 12, 2016 6:20:21 AM

Thanx for the fast reply. I tried the SD card in another phone and it's fine...also tried 2 other SD cards (64GB, 32GB and 4GB) brand new and they weren't recognized or mount...but they were OK in my other Samsung phone. So it must be either the slot or and app using the card. How do I run my phone in 'safe mode'?
m
0
l
Related resources
July 12, 2016 8:38:18 AM

OK. I figured out how to enter safe mode. Still will not mount (or recognize) any SD card....so I guess it's the slot. Is there really a way to repair/replace it? is it worth it?
m
0
l

Best solution

July 12, 2016 1:52:03 PM

One other thing you might try first, see if there are any Firmware updates for the phone. And be sure to restart it after checking (no matter if you get one or not) then try the card again.

If that doesn't help, and it is under warranty, you could see if the manufacturer will repair or replace it. If it isn't you have the option of trying to do it yourself. If you feel you can, or taking it to a local tech/shop to have it replaced. The part may not be to costly, but the work involved could be.
Share
September 5, 2017 9:59:10 AM

If it's a new micro sd card
Get a windows computer:
On the start menu right click on my computer then click manage, it takes you to the console, then go to disk manager then right click on the not mounting disk then click on properties then select hardware it should show your disk, select it then click on properties choose volumes then click on populate.
That's all you need to do for your android device to mount it
m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS