Your question

iPhone 5 Restore Problem... HELP!

  • iPhone
  • iPhone 5
Last response: in iPhone
October 27, 2013 8:48:02 PM

So I restored my phone couple days ago and it keep getting stuck on "Restoring iPhone firmware..." After 20 minutes it makes an pop-up and said "An error occurred (3)" I search Error 3 and found out that there's no "error 3"... Im getting really frustrated about this problem... It's not restoring the dam iPhone... On the iPhone, it shows the bar 95% done and the 5% is left or the next 20 minutes... I tried to restore over 6 times and no success... Any ideas that could help ASAP

More about : iphone restore problem

October 27, 2013 9:19:00 PM

Have you tried talking to Apple ?
October 27, 2013 9:27:33 PM

No, I'd figure they wont know anything... I seem to be the only one to have this problem in the world... I search the Web and got nothing for the past few days...
Related resources
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS