Your question
Closed

Asus keyboard issue

Tags:
  • Laptops
  • Keyboards
Last response: in Laptop Tech Support
January 4, 2013 12:06:54 AM

Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)

More about : asus keyboard issue

a b D Laptop
January 4, 2013 2:41:46 AM

Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 
Score
2
May 7, 2014 5:07:06 PM

lvw said:
Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)


I had a terrible problem with this on my laptop and I found a clever solution thanks to Denzil on youtube (https://www.youtube.com/watch?v=p8J7TJBSBPo)

Open up notepad and copy

set WshShell = CreateObject("wScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

And paste into notepad. Save as whateveryouwanttocallit.vbs

Click on the file and it will turn on and off your num lock which was the source of the problem (repositioning the layout.)

Hope that helps.

Cheers,

Ace
Score
1
Related resources
Can't find your answer ? Ask !
September 9, 2014 5:58:13 AM

Tibbs01 said:
Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 



This works for me thanks allot......

Score
0
October 17, 2014 1:53:42 AM

Ace Edge said:
lvw said:
Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)


I had a terrible problem with this on my laptop and I found a clever solution thanks to Denzil on youtube (https://www.youtube.com/watch?v=p8J7TJBSBPo)

Open up notepad and copy

set WshShell = CreateObject("wScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

And paste into notepad. Save as whateveryouwanttocallit.vbs

Click on the file and it will turn on and off your num lock which was the source of the problem (repositioning the layout.)

Hope that helps.

Cheers,

Ace


It worked nicely! Thanks Ace.

Some Asus laptops do not have the "numlock" key to enable/disable it so whenever you disconnect an external keyboard with the numlock on you laptop's keyboard remains in such state without being able to disable it. Ace's short script does the job!
Score
0
January 13, 2015 12:54:24 PM

Ace,

You are right on the money. The VP Script was perfect for those ASUS laptop keyboards missing the NumLock function override. Nice answer, it fixed the issue!
Score
0
February 4, 2015 6:44:08 AM

lvw said:
Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)


It took me more than a week to locate the ''num lk'' button on the asus note book. Its located on the right top corner of the key pad under the ''delete'' button on the ''home'' button. Once you locate the button then it is easy. Press the "fn" and "numb lk" buttons together.
Score
0
February 27, 2015 10:26:04 PM

Tibbs01 said:
Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 


This was really helpful! :wahoo: 
Score
0
August 15, 2015 6:10:49 AM

Ace Edge said:
lvw said:
Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)


I had a terrible problem with this on my laptop and I found a clever solution thanks to Denzil on youtube (https://www.youtube.com/watch?v=p8J7TJBSBPo)

Open up notepad and copy

set WshShell = CreateObject("wScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

And paste into notepad. Save as whateveryouwanttocallit.vbs

Click on the file and it will turn on and off your num lock which was the source of the problem (repositioning the layout.)

Hope that helps.

Cheers,

Ace



The above script by Ace works like a charm - 1 minute solution. RIDICULOUS that Asus does not have a simple way around this!!! Thanks Ace!!
Score
0
February 1, 2016 1:43:51 PM

Tibbs01 said:
Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 


Score
0
February 1, 2016 1:44:25 PM

I tried this but it did not work....how do I turn on num lock
Score
0
March 20, 2016 10:16:30 AM

anabela said:
I tried this but it did not work....how do I turn on num lock


Ensure that you saved the text file/Notepad file as a .VBS instead of .txt or it will do nothing when you double click on it except to just open the file

Score
0
March 27, 2016 11:36:29 PM

Tibbs01 said:
Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 


I had this problem but got it resolved. My keyboard did not work. I was lucky that I stumbled into the "Ease of Access" and found out that my "on-screen Keyboard" was on. I turned it off and my keyboard works now!

QT
Score
0
April 17, 2016 5:22:38 PM

kamal98 said:
Tibbs01 said:
Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 



This works for me thanks allot......


this doesn't work for me... why? i have to use on screen keyboard ;-;

Score
0
May 9, 2016 8:37:31 AM

TheBoxedHobo said:
kamal98 said:
Tibbs01 said:
Hold your function key and press the "num lock" labeled button up above your F keys (I think the scroll lock in white writing, num lock in blue). This will normally happen if you have used an external keyboard and turned num lock on. When you disconnect the keyboard it stays locked....or you might have just accidentally turned it on yourself :) 



This works for me thanks allot......


this doesn't work for me... why? i have to use on screen keyboard ;-;



While the regedit fix worked for me, it did not work with keyboards in other languages, as my accent keys would not work. Spoke to ASUS support. Here's the fix. In the search box at bottom left, type Onscreen Keyboard and select it. A different keyboard will pop up than the one you get it you hit the keyboard icon on the task bar. Hit the OPTIONS button and click in the box to turn on numeric keypad. Then hit OK. The NumLock button will appear bottom right of the on-screen keyboard. Here is where you toggle it on and off.
Score
0
June 10, 2016 8:30:21 AM

Finally this worked for my eee PC 1000H with Win7 and Now Win10. I tired some many APK files nothing seemed to work. My FN keys still dont work 100% correctly but at least i can type using all the letters on the keyboard now. Thank you!

----------------------------------------------------------------
Open up notepad and copy

set WshShell = CreateObject("wScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

And paste into notepad. Save as whateveryouwanttocallit.vbs

Click on the file and it will turn on and off your num lock which was the source of the problem (repositioning the layout.)


Score
0
July 10, 2016 8:45:03 AM

lvw said:
Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)


Score
0
August 4, 2016 10:16:55 AM

Hello. If you still haven't found a working solution, you might want to read on.

I had a similar issue: the buttons "4, 5, r, t, f, g, v and b" refused to be used on an ASUS F550J laptop.

CAUTION: In order to not break your computer, ask a friend who has skills in the hardware area or ask for technical support.
EXPLANATION to the fix: The main problem is that the cable, which transfers data from keys to the processor, is touching a hot steel/iron/etc. This causes data loss and the keys permanently stay unusable or at least barely usable.

STEPS to fix:
1. Make sure you know what you're doing.
2. Turn off the laptop.
3. Turn the laptop upside-down.
4. Unscrew every bolt you find.
5. There might be a couple screws under the battery. If so, carefully remove it and unscrew them as well.
6. This steps requires patience: Split the keyboard part from the rest of the laptop but know that there are going to be cables connected underneath. Slowly separate the two parts. Check how on YouTube. It's easy but make sure you have everything unscrewed. Don't unclip any cables, you won't need it. (If you're having trouble later on, you could unclip some but make sure you're very careful, because each has a clip, you need to click.)
7. This is the main step: Make sure you fold the most wide cable, so it doesn't touch any metal. Be careful with the folding, it's delicate. (You might want to straighten the folded area, which was touching the metal. This way, it refreshes.)
8. After you've folded the wide cable without it touching any metal, put the keyboard part back onto the other one. Make sure the wide cable is how you've put it (not touching metal) and is staying that way after the close.
9. Flip the laptop again, whilst making sure you have the cable as you want it.
10. Screw all bolts.
11. You're done. Now check if you've found your fix.
Score
0
August 4, 2016 10:07:43 PM

Ace Edge said:
lvw said:
Hello,
the m,j,k,l,u,i,o,8,9,0, keys all have a small number on the right side of the key. My keyboard wont' type the letter wtihout also holding dow the "function" (fn) key !! How can I "set" somethign so that I can type the letters and not these little numbers?! (already has number keys across the top which work fine!)


I had a terrible problem with this on my laptop and I found a clever solution thanks to Denzil on youtube (https://www.youtube.com/watch?v=p8J7TJBSBPo)

Open up notepad and copy

set WshShell = CreateObject("wScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

And paste into notepad. Save as whateveryouwanttocallit.vbs

Click on the file and it will turn on and off your num lock which was the source of the problem (repositioning the layout.)

Hope that helps.

Cheers,

Ace


I love this solution. Quick and easy turn on and off numlock whenever you would like just by double clicking the script on your desktop. It works great for me because my Asus Laptop does not have a numlock button.
Score
0
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS