Your question

Left clicks not registering in games sometimes, using Asus G73JH-BST7

  • Mice
  • Games
  • Laptops
Last response: in Laptop Tech Support
November 21, 2011 4:20:46 PM

Okay guys, on my Asus G73JH-BST7 I am noticing that when playing games sometimes the left mouse clicks don't register. I have no earthly idea what this is, as the mouse works perfectly fine in Windows - it's just games it acts stupid in. I even connected a wireless mouse and disabled the trackpad and still some of my left clicks do not register. In Minecraft and TF2 it seems to only work sometimes despite me clearly pressing the button - in Metro 2033 for some reason it never seems to act up. What is this, I just don't understand this problem. Is there some service that can be making my mouse clicks not register?

Come to think of it the right mouse click doesn't always register either - was trying to play L4D and it didn't always work. Anyone have a clue what's wrong?

EDIT: In my googling attempts to find the answer to this problem I found someone mention stack overflow - and then as I opened a webpage I had a stack overflow error! Is this possibly the problem, and if so how do I fix it? Something to do with the memory - but it has 6 GB. I'm noticing once in a good while when I am typing it will not register one letter - but I just tried to repeat this and it wouldn't do it despite typing the same word repeatedly, though just now it didn't register the space one time. How can I fix this?

EDIT 2: Okay I should rephrase this - MOST of the time I click the buttons they don't work. But if they work and I hold it down it keeps working. Tried some more L4D, frantically smashed the left key and then right key and rarely would the gun shoot in time before a zombie got to me. What the hell is wrong with this thing, if I can't get this fixed this is a high powered note taking laptop - it's impossible to play games like this!

More about : left clicks registering games asus g73jh bst7

a b D Laptop
November 21, 2011 6:48:46 PM

ok, lets start from beginning. Are you playing the games online or offline? cause that's a big difference and in multiplayer online games you are likely to "lose" mouse clicks due to lag.

if you're in offline, then you have to look at your mouse. Are the drivers latest for your motherboard? how about does the mouse have custom drivers by manufacturer? if your mouse is wireless have you tried a wired mouse? If you think the mouse is having problems ask some friend to try it on his computer and see if the bahavior carries over to their machine.

another thing, when you're running those games how's the FPS? any dips during the lost mouse clicks?
November 21, 2011 8:31:15 PM

I have tried them both offline and online - the symptom seems to be identical either way. I tried a multiplayer server in TF2 that was low ping (around 60-ish ms) on my university's high speed broadband, so I'm quite certain it was not server lag but the mouse.

I'm not certain if the drivers for the motherboard are the most current - the Asus Live utility checks for lots of those kinds of things and I just updated it with everything it wanted and this issue persists. The mouse is a Microsoft 3000 series wireless mouse, it was extremely close to the sensor and the signal through mouse properties was reported as good. It should be noted that this problem occurs with the integrated trackpad on the laptop as well as an external mouse - I'm thinking this is software related.

I have set the mousepad to disable when the external mouse is plugged in so it is incapable of receiving input or messing anything up while the mouse is plugged in. I have not tried a wired mouse but given this issue is consistent on the built-in trackpad and an external mouse I don't think a wired mouse will be any different. The wireless mouse I am using I used for a long time on my previous laptop and it never had any issues. As I said, when I'm in Windows the mouse works just fine and doesn't do anything stupid - but when I'm in game the mouse likes to not register clicks many times. I can get it to click eventually but only on its terms - I've tried holding it down, mashing it repeatedly, nothing seems to work until it just decides it wants to work.

FPS on the games is great, easily solid around 60 FPS avg. The games don't slow down at all when I'm trying to click, and there's no stutter or anything when it does fire - it literally acts like it isn't receiving the command from the button - and whatever it is doesn't matter if it's an external mouse or the built-in trackpad. What's really stupid, it's game dependent it seems if the mouse will act stupid or not too. When playing Metro 2033 the mouse responds like it should on cue with no stupidness at all. But if I load up TF2 or L4D it starts acting strange. At first I thought it was just source games, but Minecraft is doing the same thing not registering clicks so I'm at a loss for a common problem source.

I have about 90 processes running - I checked them several times and I've eliminated every thing that can be eliminated. The processor and memory usage levels both never exceed normal levels and don't look very stressed so I don't think it lacks the ability to do what it is being asked to do. I am wondering if the hyperthreading is having an effect on this. I tried looking into disabling hyperthreading but see no way to do so (No BIOS setting for it) - and every place I see on the internet just has someone belittling someone for asking how to disable HT. I've heard that HT can cause games that aren't optimized for quads to run poorly - hard to imagine Source games being non-optimized though.

A drastic option I'd prefer to avoid, but I could try plugging in a different hard drive and removing the current one to see if the issue is software or hardware related. Any other ideas on what I can do to rectify this issue?

EDIT: Just noticed while trying to test Minecraft it runs horribly - and yet Metro 2033 with DX11 and settings on high runs good...I looked at the clocks and the CPU was at around 1-1.4 GHz when the game lagged horribly. Why is my i7 cranking down so low like it isn't doing anything when I'm playing a game like Minecraft? Makes no sense how Minecraft lags but Metro rocks...
a b D Laptop
November 22, 2011 1:36:11 AM

oh ok, i think it might the cranking down that's causing the lag.

when you start the game, alt tab out and go to the process. right click and select to set affinity. Uncheck all except one core and see if that helps any.
November 22, 2011 7:08:14 AM

I tried Minecraft on dual core affinity and single core and it still ran shoddy - didn't fix the mouse problem either. After this I got frustrated and just went through the process list closing tons of stuff, including some Asus management software and ATI stuff. I got the processes down to about 70, tried the games - works perfect! I don't know which program is doing it or if it's the work load, but something was making the games act stupid that when I close through the programs makes them register clicks just fine. I still don't know why Metro registered mouse clicks just fine with the same work load that made the others not work, but I'm happy that the mouse works just fine nonetheless.

Now I'm curious why Metro 2033 runs on DX 11 high smoothly and Minecraft is jerking all over the place every so often and not running near as well. Any ideas on that?
November 23, 2011 10:39:11 PM

Cool, that's a nice automated way to take care fo what I do usually when I boot up my computer. Using that program I definitely am eliminating whatever the background program is that's the problem - nice that I can easily turn the gamebooster off and restore the processes when I'm done too. Thanks, you've been a big help!
November 23, 2011 10:39:33 PM

Best answer selected by RavinRivie.
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS