Your question

Windows could not start because of a computer disk...

  • Computer
  • Windows XP
  • Laptops
Last response: in Laptop General Discussion
May 27, 2010 5:33:27 PM

i got a eee pc 1005ha and it came with windows xp home edition in portuguese installed on it
i wanted to install the professional in english, but i heard that i would loose my warranty if i had some problem after that, so i decided to keep the home edition in one partition and install it in another partition
so i used the wintoflash software to create a bootable usb
the first problem that i had, was that i couldn't see my partitions in the installation menu...then i changed in the bios the SATA config from AHCI to IDE and it worked, so i formatted the partition and installed the xp, but, after the computer restart, when i choose to go to GUI to continue the install, it crashes and keep restarting and showing the boot options
then, when i start windows normally, without booting, it shows me a dual boot menu. if i try to go to xp home edition, it shows the windows xp image but it crashes and restarts and if i try to go to windows professional, it shows me a message:

Windows could not start because of a computer disk hardware configuration problem.

Could not read from the selected boot disk. Check boot path and disk hardware.

Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information.

I changed back from IDE to AHCI and now i can enter normally in xp home edition, but when i try the professional, it still shows me this message.

Anyone can help me?

More about : windows start computer disk

May 27, 2010 7:08:12 PM

I've finished the windows installation by choosing "debug boot rdisk 1 partition 2" option in the boot menu and now, I still get the "Windows could not start because of a computer disk hardware configuration problem" message when i try to select it in the dual boot menu. I can just use the Professional edition if I boot from the usb and select the debug option. Another thing, I have to change to IDE option in the SATA config to use it, otherwise it crashes just like if try to use the home edition with IDE option.
Related resources
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS