Your question
Closed

Realtek HD Audio-Manager:One sound signal simultaneously on front+rear

Tags:
  • Drivers
  • Headphones
  • Realtek
  • Audio
  • Apps
Last response: in Apps General Discussion
January 14, 2012 12:28:06 PM

Hey there,

I've googled quite a bit but can't find the solution. I got an onboard audio which comes with the Realtek HD Audio-Manager. I've plugged in my headphones in the front and my stereo in the rear - but Realtek doesn't allow me to send the same audio signal to front and rear simultaneously. I've to unplug the headphones every time I want to use the stereo and replug if I want to use the headphones. Any ideas how to solve that?

There is an option to stream two different signals to front and rear simultaneously but not the same signal. Hope you know a solution?

Greets
smoo

More about : realtek audio manager sound signal simultaneously front rear

a b \ Driver
January 17, 2012 11:27:30 AM

You need to disable "front panel jack detection".

February 15, 2014 7:34:31 AM

I don't have that option!!
I have TWO headphone sockets (running win7 dell xps l502x, hd audio manager devDriver 6.0.1.7106 )
one maybe spdif, I don't know...

when I plug in normal headphones they both work at same time, but speakers go off... have HD but no devices! JBL speakers and sub-woof inside are amazing...

Does anyone have the ability to monitor the reg, to see what the impact is (@ reg level) when ticking the "disable jack detection" option?
Related resources
Can't find your answer ? Ask !
June 6, 2014 10:48:11 PM

Hawkeye solution works for me, thanks!!

Windows 7 x64 ALC892 chipset
December 3, 2014 5:35:01 PM

The solution posted by Hawkeye works for me too. Note his red arrow pointing to yellow icon near top-right. But you must also click Device Advanced Settings at top-right and make sure that the top option/button under Playback Device is selected.

I'm running Windows Vista SP2. Yeah I know, it's no longer a supported Microsoft OS.
April 17, 2015 4:48:54 PM

I'm having a similar situation and my Realtek HD Audio Manager doesn't have the yellow folder icon mentioned above so I can't make that change. It's an Asus P5K Pro MB running Windows 8.1 64bit. Any suggestions?
May 20, 2015 2:39:59 PM

Ross Baseler said:
I'm having a similar situation and my Realtek HD Audio Manager doesn't have the yellow folder icon mentioned above so I can't make that change. It's an Asus P5K Pro MB running Windows 8.1 64bit. Any suggestions?


If your Audio Manager looks like mine, there is a gear in the top right next to the close and minimize window buttons. I clicked the gear and then changed the "Connector Settings" from "HD Audio Front Panel" to "AC97 Front Panel."
May 31, 2015 3:08:01 AM

ASUS H97-PLUS with Realtek ALC 887, Bitfenix shinobi with AC97/HD (selectable by connector), installed latest ASUS driver V6017354 from ASUS website.

Audio split doesn't work, no option to split or to inhibit front detection in Realtek audio manager- neither AC97 nor HD.

Tried newest REALTEK HD driver from their website - the same problem.

Found the solution in http://www.tomsguide.com/forum/59341-6-solved-split-rear-panel-audio-jacks-separate-audio-streams : uninstalled Realtek crap, after reboot, the chip is driven by native windows 7 drivers. They will allow me to split whether AC97 or HD.

After pluging in my headphone in the front, I got it as playback device "headphone" in addition to my speakers.
Since I want to use it for Microsoft Flight Simulater (FSX) to separate engine noise from tower voice, I had to change the headphone to "default communication device" (right click).

Now, my speakers are the default device and my headphones are the default communication device.
In FSX, my sound settings are "sounds : <default device>" and "voice <default voice device" (which means default communication device in Windows).

Another hint: setting the default format of REALTEK playback devices to "16bit, 44100 Hz (CD)" in opposite to the default "DVD" (properties playback device, advanced) gains remarkable performance (tested with REALTEK driver, not tested with Win7 default driver) - I earned 5-10% CPU on an i3-4340 (independent from the game).
June 16, 2015 2:49:37 AM

Jonny9781 said:
I don't have that option!!
I have TWO headphone sockets (running win7 dell xps l502x, hd audio manager devDriver 6.0.1.7106 )
one maybe spdif, I don't know...

when I plug in normal headphones they both work at same time, but speakers go off... have HD but no devices! JBL speakers and sub-woof inside are amazing...

Does anyone have the ability to monitor the reg, to see what the impact is (@ reg level) when ticking the "disable jack detection" option?

Try this , go to Control Panel then, All Control Panel Items, switch to large icons, then click Realteck HD audio manager.
when open click the little cogwheel in the left hand corner, device advanced settings wil open check the Separate all input
jacks settings, should work ;) 
Made a acoubnt just to awnser this
December 20, 2015 8:44:44 AM

vvega said:
The solution posted by Hawkeye works for me too. Note his red arrow pointing to yellow icon near top-right. But you must also click Device Advanced Settings at top-right and make sure that the top option/button under Playback Device is selected.

I'm running Windows Vista SP2. Yeah I know, it's no longer a supported Microsoft OS.


Thank you! It worked but after updating driver it didn't work anymore. Thanks for the second hint too "make sure that the top option/button under Playback Device is selected". Unlogical but after this it works again! :) ))
October 23, 2016 11:43:27 PM

Since this is my google result, let me tell you my solution. Instead of there being a gear on the right or left of the panel screen, it is just text that says "Device Advanced Settings". Click on that text and you get a popup with two options: (1) Mute the internal plrayback device when an external headphone plugged in ---- (2) make internal and external output devices playback be two different audio streams. Choose the (2) lower option instead
November 11, 2016 1:34:13 PM

I use this. (No Hardware required)
You can split the sound between any device. Ive split upto 3 devices and sound is stable. I fixed sync issues by adjusting the Total Buffer size between both apps. Other than that, its simple fast and works. Enjoy.

https://www.youtube.com/watch?v=QRZIX5O7ESI
February 22, 2017 9:01:54 AM

UnknownAdmin said:
ASUS H97-PLUS with Realtek ALC 887, Bitfenix shinobi with AC97/HD (selectable by connector), installed latest ASUS driver V6017354 from ASUS website.

Audio split doesn't work, no option to split or to inhibit front detection in Realtek audio manager- neither AC97 nor HD.

Tried newest REALTEK HD driver from their website - the same problem.

Found the solution in http://www.tomsguide.com/forum/59341-6-solved-split-rear-panel-audio-jacks-separate-audio-streams : uninstalled Realtek crap, after reboot, the chip is driven by native windows 7 drivers. They will allow me to split whether AC97 or HD.

After pluging in my headphone in the front, I got it as playback device "headphone" in addition to my speakers.
Since I want to use it for Microsoft Flight Simulater (FSX) to separate engine noise from tower voice, I had to change the headphone to "default communication device" (right click).

Now, my speakers are the default device and my headphones are the default communication device.
In FSX, my sound settings are "sounds : <default device>" and "voice <default voice device" (which means default communication device in Windows).

Another hint: setting the default format of REALTEK playback devices to "16bit, 44100 Hz (CD)" in opposite to the default "DVD" (properties playback device, advanced) gains remarkable performance (tested with REALTEK driver, not tested with Win7 default driver) - I earned 5-10% CPU on an i3-4340 (independent from the game).


This is the only "solution". getting rid of the "aftermarket" drivers and let Windows 10 update find the audio drivers. for some stupid reason, this MOBO (I have the same model, perhaps happens in other models made by Asus) do not let you have 2 separate audio outputs from front and back audio jack. the dead MSI board (based on h87 chipset) I replaced with the asus one used to let me do this with the realtek drivers installed. this one doesn't.
April 18, 2017 10:34:37 AM

Got rid of aftermarket drivers did a restart and when it booted everything was perfect and for some odd reason it became one audio again
July 28, 2017 3:19:59 AM

Just thought id give my more or less useless input on this subject:

Im a long time user of Asus mobos, for about 20 years. I like their BIOS and print design/layout, all the little things that makes it easier to connect various devices as well as (mostly) genius cabling/plug solutions. BUT... The onboard soundcard... Its a nightmare; first it was AC'97 and finding a proper driver for this taiwan chip. Then it changed name but still used the same driver. Then the driver changed name and so on and so on. Now we have this socalled 'SUPREME FX'. A title that makes me laugh and cry at the very same time. Asus should really know better IMVHO. I see ads of this and that, neon lights and laser sounds. Awesome mobos with great stats - but with OEM chip...
August 11, 2017 7:49:56 PM

I've had the same problem, and figured I'd post a solution here to anyone else that comes across this thread. I have a lenovo laptop with the realtek audio and when my headphones are plugged into the 3.5mm audio jack they are the only audio recognized in my playback devices (so I can't disable headphones and enable speakers to switch..I've had to remove the headphones physically to switch).

So what I did to solve this is go to 'Sound Manager' in your Realtek HD Audio Manager, in upper right corner I see 'Device Advanced Settings', and below that is a yellow folder, but below that is a black circle.
Right click on that black circle and select 'Connector Retasking...' and it asks "Which device did you plug in?", and I then select the 'Mic in' box instead of the 'Headphone/Headset'.

This now allows me to switch from my Headphones audio output to my speakers audio output without physically removing my headphones from the 3.5mm jack. I wish they'd make it easier, but I'm just glad to finally have a workaround.
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS