Your question
Solved

Wierd laptop display issues. Works only on Linux. [Dell, Inspiron 15, N5010] [Radeon HD 5650/5470/4200/550v]

Tags:
  • Dell
  • Laptops
  • Displays
  • Linux
  • Dell Inspiron
  • Graphics Cards
  • HD
  • Radeon
  • Configuration
Last response: in Laptop Tech Support
July 26, 2017 4:07:14 AM

SPECS:

The laptop is a DELL, Inspiron 15, N5010.

The graphic card is AMD ATI Mobility Radeon HD 5650/5470/4200/550v.

I installed two OS, Manjaro KDE and Windows 7.

THE PROBLEM:

When I turn on the laptop nothing displays. Usually the boot menu is displayed giving me a choice between the OS installed. But now when I turn on the laptop the screen won't turn on; but if I leave it like that Manjaro KDE is eventually selected after 5 sec timeout, then screen eventually switches on but with issues.

Manjaro KDE boots up saying:

It says `[radeon] *ERROR* UVD not responding, trying to reset the VCPU!

And when it does either the screen is less the display is slightly garbled or completely garbled.

If I select Windows 7 or try to enter BIOS nothing is displayed on the screen. I don't think the screen is even switched on then. Mind you when the laptop starts nothing is displayed (the display is on only when Manjaro boots up), I know hitting `DEL` key will go to BIOS and selectiong the third option by pressing `down key` two times gets me to windows.


https://imgur.com/a/SRN33

More about : wierd laptop display issues works linux dell inspiron n5010 radeon 5650 5470 4200 550v

Best solution

a b D Laptop
a b U Graphics card
July 26, 2017 5:36:16 AM

The GPU is gonna die soon. Try turning the laptop on by holding "D" and press power. It should go through a video test then start normally. You will most likely need to send the laptop into a service and have it reflowed.
Share
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS