Your question
Solved

ASUS ROG GL552VW - backlit keyboard not working

Last response: in Laptop Tech Support
February 1, 2016 1:57:27 AM

Hello dears!
Just bought a new laptop ASUS ROG GL552VW with Windows 10 on board and found that backlit keys are not working at all(Fn + F3/F4). All other combinations are workinf fine (Fn + F#).
I had updated all drivers(including BIOS) from official site Asus but it didn't help.

Do you have any ideas what should I do?
I read a lot of articules that Win10 could be the reason. So maybe I need to reinstall OS to Win 8 or Win7(they both are ok for me)

P.S. Variant exchange it to the new is not for me due to some reason. :( 

More about : asus rog gl552vw backlit keyboard working

February 1, 2016 3:25:32 AM

Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 
m
3
l
February 1, 2016 4:15:47 AM

Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


Thank you for your answer! :) 

Both these cases I tried. And they didn't help me. I have called to the ASUS Support and they suggested to visit their Service Center what i'm planning to do tomorrow.

I will write a result here :) 
m
0
l
Related resources
February 1, 2016 5:44:29 AM

Thanks for posting back and I look forward to hearing the hopefully positive result they supply you with.

Good luck my friend.
m
0
l
February 2, 2016 8:17:49 AM

Slava_L said:
Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


Thank you for your answer! :) 

Both these cases I tried. And they didn't help me. I have called to the ASUS Support and they suggested to visit their Service Center what i'm planning to do tomorrow.

I will write a result here :) 


Incase you are still looking for a solution - do this below.

go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey (or wherever you have your program files)

run hcontrol.exe

REgards
Joe
m
0
l
February 3, 2016 1:16:32 AM

MavsVj said:
Slava_L said:
Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


Thank you for your answer! :) 

Both these cases I tried. And they didn't help me. I have called to the ASUS Support and they suggested to visit their Service Center what i'm planning to do tomorrow.

I will write a result here :) 


Incase you are still looking for a solution - do this below.

go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey (or wherever you have your program files)

run hcontrol.exe

REgards
Joe


:) 
Firstly I will need to check if hcontrol.exe is runnig (in task manager). And if not - i should run it. otherwise i need to delete this process from task manager and then run it (as you described)
This was one of first thing which i have checked.
In any case thank you for your answer!
I passed my notebook to service center. I'll let you know the result of error fixing (positive or negative) here.
P.S. Sorry for my English. It's not my native language :) 
m
0
l

Best solution

February 3, 2016 5:20:36 AM

Hello all!
The problem has been solved! :)  The reason was a stub ( for backlight).

So please note that not only drivers or other soft could cause such problems!
Share
March 21, 2016 1:05:39 AM

Slava_L said:
Hello all!
The problem has been solved! :)  The reason was a stub ( for backlight).

So please note that not only drivers or other soft could cause such problems!



Hi,

I am also having thesame problem. What stub?
m
0
l
March 21, 2016 1:47:36 AM

Alexson said:
Slava_L said:
Hello all!
The problem has been solved! :)  The reason was a stub ( for backlight).

So please note that not only drivers or other soft could cause such problems!



Hi,

I am also having thesame problem. What stub?


Hi,
Stub example: http://goo.gl/Zsfr06

They inform me that it was broken in the assembly. So it was a warranty case.
m
0
l
August 4, 2016 10:26:58 AM

Hello. If there are people who are still experiencing the issue, here's my fix.

I had a similar issue: the buttons "4, 5, r, t, f, g, v and b" refused to be used on an ASUS F550J laptop.

CAUTION: In order to not break your computer, ask a friend who has skills in the hardware area or ask for technical support.
EXPLANATION to the fix: The main problem is that the cable, which transfers data from keys to the processor, is touching a hot steel/iron/etc. This causes data loss and the keys permanently stay unusable or at least barely usable.

STEPS to fix:
1. Make sure you know what you're doing.
2. Turn off the laptop.
3. Turn the laptop upside-down.
4. Unscrew every bolt you find.
5. There might be a couple screws under the battery. If so, carefully remove it and unscrew them as well.
6. This steps requires patience: Split the keyboard part from the rest of the laptop but know that there are going to be cables connected underneath. Slowly separate the two parts. Check how on YouTube. It's easy but make sure you have everything unscrewed. Don't unclip any cables, you won't need it. (If you're having trouble later on, you could unclip some but make sure you're very careful, because each has a clip, you need to click.)
7. This is the main step: Make sure you fold the most wide cable, so it doesn't touch any metal. Be careful with the folding, it's delicate. (You might want to straighten the folded area, which was touching the metal. This way, it refreshes.)
8. After you've folded the wide cable without it touching any metal, put the keyboard part back onto the other one. Make sure the wide cable is how you've put it (not touching metal) and is staying that way after the close.
9. Flip the laptop again, whilst making sure you have the cable as you want it.
10. Screw all bolts.
11. You're done. Now check if you've found your fix.
m
0
l
August 27, 2016 7:01:10 AM

Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


this is best answer. it works!
m
0
l
December 30, 2016 5:55:24 AM

Thanks gan
m
0
l
February 3, 2017 7:18:11 AM

Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


Thanks! it works :) 
m
0
l
February 3, 2017 8:20:48 AM

MavsVj said:
Slava_L said:
Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


Thank you for your answer! :) 

Both these cases I tried. And they didn't help me. I have called to the ASUS Support and they suggested to visit their Service Center what i'm planning to do tomorrow.

I will write a result here :) 


Incase you are still looking for a solution - do this below.

go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey (or wherever you have your program files)

run hcontrol.exe

REgards
Joe


Thank you!! this works perfectly on my
ROG G752VY

I did a full windows 10 clean install after putting in a Samsung EVO 960 1Tb SSD, and now i'm getting the odds and ends to work again :)  very very grateful!
m
0
l
February 16, 2017 7:27:09 PM

In my case i upgrade to win10 PRO and the ATK not installing by my provider. I download the ATK for win10 pro, restart the lap and the backlight working pressing the fn+f4.
m
0
l
March 3, 2017 12:58:54 PM

Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 



Thank you very much it help peace from Medenine,Tunisia :)  !
m
0
l
June 23, 2017 3:01:08 PM

Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 



Thanks. This worked for me :) 
m
0
l
July 20, 2017 8:32:54 PM

oh my god,thank u so much Joe, IT WORKS.

Best regards,
Sam, from Malaysia
m
0
l
September 11, 2017 6:45:07 PM

MavsVj said:
Slava_L said:
Cloudy1 said:
Did Windows 10 come pre-installed?

Regardless....here are two things you can try, both of which have worked for various people under differing circumstances with similar ASUS models:

1) If you have been FULLY SHUTTING DOWN the machine and then restarting....try SIMPLY RESTARTING the machine to see if it solves the issue

2) Go to the ASUS Support site for your country of origin and enter the product Model and Model Number ->
Select the Drivers and Tools Link ->
Select your OS ->
Download the ATK package...save to Desktop ->
Open Control Panel ->
Open Programs and Features ->
Uninstall current ATK package ->
Restart the computer ->
Double click downloaded ATK package on Desktop ->
Install ->
Restart the computer

Good luck :) 


Thank you for your answer! :) 

Both these cases I tried. And they didn't help me. I have called to the ASUS Support and they suggested to visit their Service Center what i'm planning to do tomorrow.

I will write a result here :) 


In case you are still looking for a solution - do this below.

go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey (or wherever you have your program files)

run hcontrol.exe

REgards
Joe


JOE NAILED IT AND SO SIMPLE ...EXCELSIOR AND APPRECIATION

m
0
l
May 20, 2018 9:52:16 PM

For the Asus GL702VM I have had this method work twice for me.
Go to the Asus website and look up your computer.
Download the ATK Package for it.
Uninstall the current ATK, and then reinstall it.
m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS