Your question

JBL Home theatre speakers stopped working

Tags:
  • Home Theatre
Last response: in Streaming Video & TVs
January 2, 2016 1:36:33 AM

My dad has some JBL CS 460 home theatre with an onkyo receiver, the sub stopped working, it made like crackles and a bang and cut out then came back in again and did the same thing till we turned it off, but now only the two front speakers are working, the centre speaker stopped and the two rear have also stopped working, the connections are are tight, just they stopped working all of a sudden with no warning, are the speakers broken? or is there something wrong with the receiver? We have had two of the speakers fixed before by someone who fixes speaker and was highly recommended but he has gone out of business, we live in Western Australia, i don't think we have too many people who repair speakers, i can't remember which two speakers were fixed and i can't remember the cause of them breaking either.

More about : jbl home theatre speakers stopped working

January 2, 2016 8:58:09 AM

To determine if the speakers are the problem connect the center speaker to the speaker wire from one of the working speakers. If the speaker works then make sure that the receiver is not in s tereo. You can check the other rear speakers the same way. The subwoofer is another issue. It may have a bad amplifier or have received those noises from the receiver. Try to turn the sub on with the receiver off.
m
0
l
January 9, 2016 3:27:06 AM

americanaudiophile said:
To determine if the speakers are the problem connect the center speaker to the speaker wire from one of the working speakers. If the speaker works then make sure that the receiver is not in s tereo. You can check the other rear speakers the same way. The subwoofer is another issue. It may have a bad amplifier or have received those noises from the receiver. Try to turn the sub on with the receiver off.


Hey, the centre speaker works fine when plugged into the left speaker, i tried moving the speaker cable from the left speaker to the centre one on the receiver and it didn't work and then i tried a whole new speaker cable and that didn't work either. we have heaps of listening modes on our receiver and when ever we play a movie we usually have it on surround sounds setting, where all the speaker are meant to be used and only the front two work now, i have tired on every other listening mode and still only the first two side speakers work, I'm just wondering if it's a problem with the receiver, because it does sit in a cabinet that is not well aired and gets very hot.
m
0
l
Related resources
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS