Your question

Headset wont work when plug in jackstick but works fine when i use USB

Tags:
  • Steelseries
  • Elite
  • USB
  • Gaming Headsets
Last response: in Audio
May 22, 2015 1:59:56 PM

So, about 1 year ago i bought this Steelseries Siberia Elite headset, which had an issue with the jackstick. If i plugged it in, it sounded like i was underwater and the bass sucked and i couldn't hear what there was being sung if i heard a song..
But it worked fine with USB!
Now i just got a new siberia elite PRISM
and the same issue stands. Steelseries couldn't find the issue on the other headset. I just bought new computer stuff, only have ram and cpu from my old computer.

How can this be?

More about : headset wont work plug jackstick works fine usb

May 22, 2015 2:04:16 PM

Are you plugging the headsets into your jack on the case? And if so, is it the same case as what the old "stuff" was in?
m
0
l
May 22, 2015 2:24:48 PM

No, as said above. Only the cpu and ram that is the same. Rest is changed. Every screw every piece of metal. :-)
m
0
l
Related resources
May 22, 2015 2:25:13 PM

And yes, i plug it in into the front of the case, beside the power button. :-))
m
0
l
May 27, 2015 11:24:36 AM

Have you tried using the plug in the rear of the case on the motherboard to troubleshoot?

Also, what is your motherboard model?
m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS