Your question
Solved

Access Violation Error

Tags:
  • Document
  • Database
Last response: in Apps General Discussion
April 4, 2015 2:02:41 PM

I have a database purchased from a specialist supplier to maintain records of my racing pigeons.When I want to print a record I get an error after I've clicked 'print. The document does print. if I ignore, the error disappears and I can continue. If I click cancel it shuts the database down. I would like to have this error corrected. I have contacted the supplier and suggested the code on my machine is corrupt. He has become defensive and said there is nothing wrong with his code. I don't think there is but I do think something on my machine may have corrupted it.
The error I get is a program alert dialogue box and in it I get :-
Error: memory access violation
File: printer.prg
Routine:: printer enddoc
Line: 859

I have no files on my machine with the prg extension. I'm not a techie but what I suggested to the manufacturer that he emails me a patch with the correct code for line 859 (I'm assuming this refers to the code(?)) and I'll drop the file into the relevant folder, also a patch for any registry entries to correct any errors. As I said I'm not a techie and my solution may come from Uranus! Any help please to solve this would be gratefully received
Thanks

More about : access violation error

Best solution

April 4, 2015 2:31:12 PM

There is SOMETHING about your setup that the developer didn't check. Maybe you have 10x the number of pigeons he tested for or you have some text in a field that is WAY bigger than he tested or something specific about your DATA or your printer that is causing the problem. Ask the developer if there are any "switches" that would turn on additional logging that would allow him to identify the problem.

An access violation is usually a problem where a data structure in the code is exceeded.
Share
April 4, 2015 3:17:22 PM

Hi Kanewolf, thank you for your reply. I think you are right in terms of the printer being a problem. The size of the database is not a problem I would suggest, I have restarted on a new database and only put last years and this years records in. I have the old database on an old laptop. My instincts suggest that the problem is related to a previous Kodak all in one printer, which I felt was very insecure. I bought at xmas a new laser brother dcp=9020cdw printer . I had a lot of problems clearing the Kodak and its ancilliary programs from the machine and the registry, though this evening I discovered that I have not completely cleaned but I'm not sure how and whether this is an issue. I'll try ad explain. When I went into printer properties and advanced and printer processor, I have two items listed, firstly:-
Kodak easy share printer with default data types
NT.EMF 1,008
NT.EMF 1.007
NT.EMF 1.006
RAW
TEXT

and the second entry is WINPRINT and the following
RAW
RAW [FF Appended]
RAW [FF auto]
NT EMF 1.003
NT EMF 1.006
NT EMF 1.007
NT EMF 1.008
TEXT
XPS2GDI

Kodak to my mind should not be there but I don't know how to remove this and could this be causing any conflict? Further advise gratefully received
m
0
l
Related resources
April 4, 2015 3:26:50 PM

It is QUITE possible that is your problem. The database may be trying to load a library for the Kodak printer. I would provide the developer exactly what you just said and ask for help in removing the "phantom" printer from their config. There is probably a file you can edit or something that they can provide.
m
0
l
April 5, 2015 1:02:17 AM

OK thaks will pursue with supplier
m
0
l
April 26, 2015 1:50:33 AM

Well I've pursued with the printer manufacturer (Brother) they've tried a different driver and the same error occurs with this piece of software. They say the printer is fine and I think they are right because I've only had this printer since December and my previous printer a Kodak gave exactly the same error.
I have no doubt it is an error in the software but not a software fault if that makes sense but an issue with my machine that has corrupted the particular line and file. The software producer tells me quite simply I'm the only one out of thousands to have a problem and there is nothing wrong with their software which in principle I agree with.
I have asked them to simply send me a patch to replace the printer.prg file and put the correct 'line' in where the error message is, my instinct is that they are corrupt; as I say I'm not a techie and appreciate my logic may be coming out of my backside!
Any further help would be gratefully received
m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS