Your question
Solved

Acer Aspire won't turn on but seems to be charging

Tags:
  • Aspire
  • Acer
  • Power
  • Laptops
Last response: in Laptop Tech Support
November 1, 2014 9:19:13 PM

My acer aspire won't turn on, but the light in the bottom right hand corner shows it is receiving power and is on (the battery symbol and the light bulb symbol are both lite up). I have attempted taking out the battery and unplugging it and then pressing the power button for 45 seconds straight and then pressing the power button numerously for another 45 seconds and walking away for twenty minutes to "get the buildup of static out".

I just bought this from a local computer repair shop not even a week ago because my last computer an Hp pavilion was doing the same thing and the mother board had failed, I'm going to be really upset if that is so with this one, I've taken very good care of it since I've gotten it to ensure this does not happen, please any suggestions would help. (In addition I'm not very familiar with computer tech talk, so please use everyday words and simplified explanations for me, thank you)

More about : acer aspire turn receiving power

a b D Laptop
November 1, 2014 9:27:10 PM

Take the Battery out and plug in the power brick then try to turn it on, did it do anything? Do you hear the hard drive ticking?
m
0
l
Related resources

Best solution

January 10, 2015 12:51:08 AM

I've actually got the same problem. It's supposedly a common problem. The fix is supposed to be an easy "flash."
http://lowendguru.com/2010/02/how-to-fix-the-acer-aspir...
But I can't seem to get it to work on mine.
In my case however, I'm unable to get the power light to blink once I've pressed FN + Esc. when powering on the unit.
Share
March 1, 2015 7:53:29 AM

Try the Battery Reset(on back/bottom of s7)
m
0
l
March 1, 2015 9:24:28 AM

saskisam said:
Try the Battery Reset(on back/bottom of s7)


Thank you for your suggestion but to answer, ..."Yes I did." I had in fact actually tried every suggestion available to no avail.

Ultimately I solved the problem by purchasing a new replacement motherboard and memory for the laptop for a total of about $45.

After replacing these with the ones in my laptop, it powered right up. I installed a fresh OS and it has been working fine ever since.

m
0
l
June 8, 2015 10:44:12 PM

policetac said:
saskisam said:
Try the Battery Reset(on back/bottom of s7)


Thank you for your suggestion but to answer, ..."Yes I did." I had in fact actually tried every suggestion available to no avail.

Ultimately I solved the problem by purchasing a new replacement motherboard and memory for the laptop for a total of about $45.

After replacing these with the ones in my laptop, it powered right up. I installed a fresh OS and it has been working fine ever since.


I've got a aspire 5252-v333 doing the same thing. Where did you find your parts at.



m
0
l
June 17, 2015 7:51:50 PM

I too have a aspire 5252 v333 with the same probelm...where did you find the parts so cheep?
m
0
l
July 22, 2015 9:36:22 AM

saskisam said:
Try the Battery Reset(on back/bottom of s7)


Thanks for this!
m
0
l
August 3, 2015 7:46:12 AM


delaro said:
Take the Battery out and plug in the power brick then try to turn it on, did it do anything? Do you hear the hard drive ticking?


In my notebook happens the same thing.
I pushed power button, hard disk led light on for 1 second then light off.
Then I power off notebook pressing power button for some second.
I removed RAM, hard disk and wireless card and I connected another monitor with VGA cable.
When power on nothing happens.
Do you have some idea?
m
0
l
August 21, 2015 3:49:31 AM

delaro said:
Take the Battery out and plug in the power brick then try to turn it on, did it do anything? Do you hear the hard drive ticking?

I am encountering the same problem with my acer nitro v black edition. The laptop keeps on restarting again and again when the Acer logo appears (before booting)

m
0
l
November 21, 2015 7:00:46 AM

I popped the back off and learned that the factory TAPES on the sensor, it was NOT pushed in like it should be! I took off the tape, pulled the white sensor going to the power button over and used a flat head to actually push it IN the port. Tapped the power button and it immediately fired up. I've been having powering on issues since the first day I got it!
m
0
l
November 25, 2015 11:31:29 AM

I have the same problem and yes I heard ticking

I
m
0
l
November 26, 2015 11:54:10 AM

I heard that you have to take out the battery then take out the adapter then hold the power button for 30 seconds then plug in the adapter
m
0
l
December 6, 2015 8:59:47 AM

I unplug the battery and plugged in the power supply and I still do not hear the hard drive or the fan come on
m
0
l
a c 532 D Laptop
December 6, 2015 11:27:24 AM

Derek_14 said:
I unplug the battery and plugged in the power supply and I still do not hear the hard drive or the fan come on


Hi, if you want to be helped, make a new thread with all the informations you can give us.
m
0
l
March 21, 2016 1:32:43 AM

Cortneylynn1997 said:
My acer aspire won't turn on, but the light in the bottom right hand corner shows it is receiving power and is on (the battery symbol and the light bulb symbol are both lite up). I have attempted taking out the battery and unplugging it and then pressing the power button for 45 seconds straight and then pressing the power button numerously for another 45 seconds and walking away for twenty minutes to "get the buildup of static out".

I just bought this from a local computer repair shop not even a week ago because my last computer an Hp pavilion was doing the same thing and the mother board had failed, I'm going to be really upset if that is so with this one, I've taken very good care of it since I've gotten it to ensure this does not happen, please any suggestions would help. (In addition I'm not very familiar with computer tech talk, so please use everyday words and simplified explanations for me, thank you)



Mine did the same thing and I was freaking out. But in the end, it was a CD disc in the drive that was the problem. So anyone out there experiencing this, just make sure there is no disc in and try re-booting :) 

m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS