Your question
Solved

F2 to enter setup doesn't work?

Tags:
  • f2
  • Hard Drives
  • setup
  • Boot
  • BIOS
  • Aspire
  • Acer
Last response: in Laptop Tech Support
October 2, 2014 6:39:47 AM

I have an acer aspire 7741z-4643 and the bios tells me to hit F2 to enter SETUP (BIOS) at boot. No matter what I can't get the bios to load. I have upgraded the bios and it still doesn't work. The only thing I can assume is the keyboard is broken. Can anyone help me? I am trying to install windows but I cant get in and change boot priority. I tried F10 and F12. The only thing that works is pressing DEL and that gets me to boot from the hard drive. I want to boot from CD though. I removed the hard drive and it finally got me to the part where I have to press a key to boot from CD and NONE of the keys I press work. I am just beyond frustrated with this laptop. Any ideas why this is happening??? The bios update was my last option to try and get this thing to boot to bios and it is still doing the same thing so I don't think the update is the problem. It still boots into windows if I have the hard drive in the laptop no matter what.

More about : enter setup work

October 2, 2014 6:53:59 AM

plug an external keyboard into the laptop. Also look to see if there is a function key that might be turning off the F-keys.
m
0
l
October 2, 2014 6:58:39 AM

I've tried tapping the Fn key along with the f2 key to see if that was it but nope. It just completely ignores when I press F2. turns out I plugged in an old ps3 drive I had laying around and it finally forced it to boot from the DVD! once i was on the installation screen I put the laptop drive back in then when it asked about partitions, it was telling me the ps3 drive was still plugged in so i hit refresh and it loaded the laptop drive partitions. I nuked them to hell and now I am reinstalling windows!
m
0
l
Related resources
October 2, 2014 12:08:29 PM

My only problem now that windows is installed and everything is done. I have to press DEL to get windows to boot otherwise i get a black screen and never boots. Any idea why this would happen?
m
0
l

Best solution

October 2, 2014 1:29:19 PM

Any chance the laptop keyboard is damaged, such as liquid spilled on it? I had an issue with booting that drove me nuts until I tried booting without the keyboard and it worked fine... so replaced the keyboard and the laptop worked fine after that.
Share
October 2, 2014 2:43:36 PM

Try pressing other F keys, have no idea why it doesn't work, maybe press earlier/later, remember you can (usually) press ctrl+alt+del to reboot instantly if you miss it.
m
0
l
Related resources
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS