Your question

Brand new laptop, can't even run Starcraft 2 on Medium settings without 3 - 5 fps. Please help :(

Tags:
  • Performance
  • Low FPS
  • FPS
  • Graphics
  • Configuration
Last response: in Laptop Tech Support
September 26, 2014 5:10:40 PM

Hi so I would really expect this laptop to have no issues with starcraft, yet it can't even run it on medium. I have all updated drivers, please could someone advise as to the issue.

Chassis & Display
Vortex Series: 15.6" Matte Full HD LED Widescreen (1920x1080)
Processor (CPU)
Intel® Core™i7 Quad Core Mobile Processor i7-4810MQ (2.80GHz) 6MB
Memory (RAM)
16GB KINGSTON HYPER-X IMPACT 1600MHz SODIMM DDR3 (2 x 8GB)
Graphics Card
AMD® Radeon® R9 M290X - 4GB DDR5 Video RAM (Special Offer)
1st Hard Disk
1TB SERIAL ATA II 2.5" HARD DRIVE WITH 8MB CACHE (5,400rpm)
M.2 SSD Drive
240GB Kingston SSDNow mS200 mSATA (upto 540MB/sR | 530MB/sW)
1st DVD/BLU-RAY Drive
8x SATA DVD±R/RW/Dual Layer (+ 24x CD-RW)
Memory Card Reader
Internal 9 in 1 Card Reader (MMC/RSMMC/SD: Mini, XC & HC/MS: Pro & Duo)
Thermal Paste
ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND
Sound Card
Intel 2 Channel High Definition Audio + MIC/Headphone Jack
Wireless/Wired Networking
GIGABIT LAN & WIRELESS INTEL® ULTIMATE N-6300 (450Mbps)
USB Options
3 x USB 3.0 PORTS + 1 x USB 2.0 PORT AS STANDARD
Firewire
1 X 1394a FIREWIRE PORT
Battery
Vortex Series 8 Cell Lithium Ion Battery (5,200 mAh/76.96WH)
Power Cable
1 x UK Power Lead & 180W AC Adaptor
Keyboard Language
INTEGRATED BACKLIT UK KEYBOARD WITH NUMBER PAD
Operating System
Windows 7
Mouse
INTEGRATED 2 BUTTON TOUCHPAD MOUSE
Webcam
INTEGRATED 2.0 MEGAPIXEL WEBCAM

Many thanks in advance for any replies

More about : brand laptop run starcraft medium settings fps

September 26, 2014 5:15:11 PM

What does taskmanager show for CPU and RAM usage?
m
0
l
September 26, 2014 5:17:23 PM

Cpu usage is hovering around 2 - 5%
And RAM is showing as 2.88GB used.
m
0
l
September 26, 2014 5:17:45 PM

Have you tried other games?
m
0
l
September 26, 2014 5:21:50 PM

I'm in the process of installing CSGO as we speak to test it.
m
0
l
September 26, 2014 5:29:25 PM

Ok that is just the end of it, TERRARIA is running at 3 - 5 fps LOL
m
0
l
September 26, 2014 5:31:05 PM

Kadaj0 said:
Ok that is just the end of it, TERRARIA is running at 3 - 5 fps LOL


Really strange. If you set it to low settings does the frame rate increase at all? Also, perhaps the default for some reason is set to integrated over discrete graphics card.
m
0
l
September 26, 2014 5:35:47 PM

no it seems to make no difference whatsoever
m
0
l
September 26, 2014 5:37:57 PM

the resolution does however seem to make a difference. though still barely
m
0
l
September 26, 2014 5:39:22 PM

Sounds like the laptop isn't using the M290x for games. Is it something you have to boot into with AMD chips or do they work like Nvidias Optimus.
m
0
l
September 26, 2014 5:43:44 PM

It's meant to be called switchable graphics application settings, you set it to high performance and that's meant to swap it to using the M290x.
m
0
l
September 26, 2014 6:06:24 PM

Ok I just swapped from (High Performance), To power saving, and that actually INCREASED the fps substantially, but why :S
m
0
l
September 26, 2014 7:06:03 PM

Anybody got any ideas ? surely those specs should be capable of running starcraft 2/ Terraria / CSGO easily at max settings
m
0
l
September 26, 2014 7:26:55 PM

Update them drivers for the m290x.
m
0
l
September 27, 2014 4:16:37 AM

I have done so, it was the first thing I did and It doesn't seem to have made a difference.
m
0
l
September 27, 2014 4:16:59 AM

It's like the card isn't even being used .
m
0
l
September 27, 2014 6:24:57 AM

It probably isn't being used. There should be some type of AMD Control Panel of you right-click on the desktop from where you can choose the GPU you want to use.
m
1
l
September 30, 2014 2:12:03 PM

Check that switchable graphics in BIOS is enabled.

Re-configure switchable graphics to Maximize Performance under Global Settings option in Catalyst Control Center properties.

This should make the OS use the AMD GPU for everything.

You should also update the Intel GPU drivers as they are the ones doing the primary switching.
m
0
l
less than a minute ago

Kadaj0 said:
Ok I just swapped from (High Performance), To power saving, and that actually INCREASED the fps substantially, but why :S


That setting would have switched your game to the integrated graphics. It's quite possible your video card is malfunctioning. Have it checked.
m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS