Your question
Solved

acer aspire e 11 battery will not charge

Tags:
  • Battery
  • Aspire
  • Laptops
  • Acer
Last response: in Laptop General Discussion
August 13, 2014 10:29:03 PM

Battery is down to 10 %, but it will not charge. What is happening. The machine is only a month old.

More about : acer aspire battery charge

Best solution

August 14, 2014 2:10:50 AM

Maybe there is a problem of loose connection between power adapter and laptop motherboard power connector, buy good voltmeter and chack your adapter and connector both.
Share
December 27, 2014 12:59:34 PM


Acer knows that their Aspire Laptops have battery failures and they still sell them without fixing the problem. The only resolution is to spend your own money shipping the Laptop back to them and wait two weeks to get it back. They know there are problems and the elected to keep shipping faulty product because it's cheaper than fixing it. Acer believes it's cheaper because most people don't understand PC's. DO NOT BUY ACER LAPTOPS!!!
m
0
l
Related resources
January 18, 2015 2:15:30 PM

Fixed this problem on an aspire e 15 - look in your manual at the bottom of the laptop - on this model there is a battery reset pin hole - press with paper clip for four seconds - the hardware is messed up and thinks that the battery is fully charged, this will reset the system allowing the battery to charge once more
m
0
l
November 19, 2016 1:59:39 AM

I solved it! And this is crazy!!!
I have a Acer Aspire E 13, but this solution might as it seems also work on other models (and brands?).
It takes 1 second to fix, so here goes:

TAP 3 TIMES ON THE GRATE OF THE FAN (on the bottom of the computer)

Is that crazy or not?
From "0% connected charging" it changed to "2 hours 14 min to full charge", and then to counting up ("6%" and so on...)
What the **** is going on? Maybe Acer should provide a crank in the box instead?

I should also point out that there are several other people that solved it in the same way.
m
0
l
March 2, 2017 12:51:58 PM

Since this new models don't have a removable battery, they've installed a little micro switch under the bottom hatch so if you were to take the cover off to replace ram or HDD the battery gets disconnected for safety reasons. There's a little rubber pad on the bottom cover that presses a little micro switch and if that rubber pad escaped the switch won't be pressed and battery wont work. Also that little switch might get dirty inside from dust and you may try putting a drop of cleaning alcohol on it and tap it a few times.
m
1
l
Anonymous
April 21, 2017 3:54:46 PM

There is a tiny indentation/switch on the underside of my Acer Aspire E 17 that I just pressed in with a stretched out paperclip. Re-set the battery charge feature for me. I was having the same issue - battery not charging. Also tried what Scunder says below just in case - tapped 3 times on the bottom fan grate. Battery's charging now. Hope this helps you.
m
0
l
September 10, 2018 11:35:00 PM

Valentino_5 said:
Since this new models don't have a removable battery, they've installed a little micro switch under the bottom hatch so if you were to take the cover off to replace ram or HDD the battery gets disconnected for safety reasons. There's a little rubber pad on the bottom cover that presses a little micro switch and if that rubber pad escaped the switch won't be pressed and battery wont work. Also that little switch might get dirty inside from dust and you may try putting a drop of cleaning alcohol on it and tap it a few times.


I was getting the 'plugged in, not charging' and not power up without charger connected. Thanks for the solution!
m
0
l
less than a minute ago

ebyrne said:
Battery is down to 10 %, but it will not charge. What is happening. The machine is only a month old.


On an E15, E5-532 I had a battery stuck at "44%, charging," and it also wouldn't power the machine. Very strange situation. I learned about the battery reset button, which while a clever idea seems to have a problem in this unit. Mine was stuck in the down position, it seemed. There was no movement, no "click" when I pressed the button.

So I took a chance and pried the button frame up a touch from the motherboard. As soon as I booted back up, the battery now said " <time> until fully charged". I'm watching it now, and it is up to 85% and continuing to charge, ETA being 36 minutes.

So it seems a batch of the reset buttons are defective, were stuck in the reset position, and were shorting out the charging circuit. For most units, it was a delicate enough situation that a tap on the case bottom freed up the button. In my case, it took a more serious measure to solve the problem. I also put a spot of glue on the Reset hole so the next guy won't reinstate the problem.
m
0
l
Tom’s guide in the world
  • Germany
  • France
  • Italy
  • Ireland
  • UK
Follow Tom’s guide
Subscribe to our newsletter
  • add to twitter
  • add to facebook
  • ajouter un flux RSS